Systems unreachable
Incident Report for CRM-service Oy
Resolved
Incident caused by problems in the internet operator's connections.
Posted May 10, 2022 - 11:57 EEST
Monitoring
Systems are reachable again. We are monitoring the situation.
Posted May 10, 2022 - 10:57 EEST
Investigating
We are currently investigating the issue.
Posted May 10, 2022 - 10:42 EEST
This incident affected: CRM-service, Contact Portal, and Call Center.