Some CRMs unreachable
Incident Report for CRM-service Oy
Resolved
All systems are up and responding again.
Posted Oct 01, 2021 - 08:34 EEST
Investigating
Some of the CRM systems are currently unreachable. The situation is under investigation.
Posted Oct 01, 2021 - 08:13 EEST
This incident affected: CRM-service.