Update 2023-04-06 reverted
Incident Report for CRM-service Oy
Resolved
We are reverting the update that was done on 6.4.2023 7:15
Posted Apr 06, 2023 - 14:42 EEST
This incident affected: CRM-service API and CRM-service.