Slowness in the systems
Incident Report for CRM-service Oy
Resolved
This incident has been resolved. The situation affected only some customers.
Posted Sep 18, 2019 - 11:18 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2019 - 10:52 EEST
Investigating
We are currently investigating this issue.
Posted Sep 18, 2019 - 10:14 EEST
This incident affected: CRM-service.